[blfs-dev] subversion-1.7.3 (ande previous one)

Bruce Dubbs bruce.dubbs at gmail.com
Fri Feb 24 19:12:25 PST 2012


Fernando de Oliveira wrote:
> Em 23-02-2012 13:32, Fernando de Oliveira escreveu:
>> --- Em qui, 23/2/12, Bruce Dubbs escreveu:
>>
>>> De: Bruce Dubbs
>>> Assunto: Re: [blfs-dev] subversion-1.7.3 (ande previous one)
>>> Para: "BLFS Development List"
>>> Data: Quinta-feira, 23 de Fevereiro de 2012, 13:25
>>> Fernando de Oliveira wrote:
> 
> Hi, Bruce,
> 
> Forgive me for returning to this.
> 
> In the book we have the line
> 
>> SQLite-3.7.10, and Apache-2.2.21 (for the APR only) or Apache Portable Runtime
> 
> where Apache Portable Runtime points to http://apr.apache.org/
> 
> There, after the "Welcome", we read in "Recommended releases":
> 
>> The recommended releases of the several Apache Portable Runtime libraries are
>>
>>     APR 1.4.6, released Feb 14, 2012
>>     APR-util 1.4.1, released December 15, 2011
>>     APR-iconv 1.2.1, released November 26, 2007
> 
> In the book's page for Apache-2.2.21, we have cited in "Optional":
> 
>> ... APR, APR-util ...
> 
> If Apache is not installed, then APR, APR-util are required. (Of course, this is a trivial issue for server users, but I believe not for desktop ones.)
> 
> Is it reasonable in the book to eventually modify the line to:
> 
>> SQLite-3.7.10, and Apache-2.2.21 (for the APR only) or Apache
>> Portable Runtime (APR and APR-util)
> or BLFS policy prevents this modification?
> 
> I always forget the utils.

There is no policy problem.  It's been several months since I updated 
subversion and it's really not practical for an editor to check every 
possible combination of advertised dependencies.

For me, I'd have to figure out what apache files to remove and then try 
to add back the APR packages.

That said, this area should probably be reviewed.  Apache 2.4 is now out 
and the APR may be changed too.

   -- Bruce



More information about the blfs-dev mailing list