[blfs-dev] gnucash brokenness

Andrew Benton b3nton at gmail.com
Fri Feb 24 06:27:09 PST 2012


On Tue, 21 Feb 2012 23:14:44 +0000
Ken Moffat <zarniwhoop at ntlworld.com> wrote:

>  Along the
> way I found several reports that it was b0rken with guile-2.0.
> Fedora *appear* to have it working, so I followed what they are
> doing (apart from one patch to make the build less noisy).  Didn't
> work for me, so I'm all-but certain that either, or both, of
> gtkhtml3-on-current-glib/gtk (probably glib), and libguile2.0, are
> the problem.  Of course, it's also possible that fedora do something
> extra/different in gtkhtml3.

I've tried to compile gnucash but it complains it can't find slib so I
tried to install slib-3.2b, following the instructions in the book.
However, the last part (which appears to be crucial for getting slib to
work with guile, which is what gnucash wants) fails like this:

root at eccles:/tmp/slib$ guile -l guile.init -c "(use-modules (ice-9 slib)) (require 'new-catalog)"
;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
;;;       or pass the --no-auto-compile argument to disable.
;;; compiling /tmp/slib/guile.init
;;; WARNING: compilation of /tmp/slib/guile.init failed:
;;; ERROR: Syntax error:
;;; unknown location: unexpected syntax in form define
ice-9/psyntax.scm:990:67: In procedure #<procedure 25bcd20 at ice-9/psyntax.scm:989:36 ()>:
ice-9/psyntax.scm:990:67: Syntax error:
unknown location: unexpected syntax in form define

Google has lots of links to threads where people report this problem
but the only solution I can find is in this debian bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=648680
And their solution is to:
   * Disable SLIB setup for now, since SLIB doesn't support Guile 2.0
     yet.

It looks to me that slib and gnucash are completely broken. Does anyone
have the energy to get this working or should we just remove slib and
gnucash from the book?

Andy



More information about the blfs-dev mailing list