[blfs-dev] gnucash - was Re: gtkmm2 and gtkmm3...

Ken Moffat zarniwhoop at ntlworld.com
Sun Feb 19 07:26:02 PST 2012


On Sun, Feb 19, 2012 at 01:21:19AM +0000, Ken Moffat wrote:
> On Fri, Feb 17, 2012 at 08:07:04PM +0000, Ken Moffat wrote:
> > On Fri, Feb 17, 2012 at 10:59:07AM -0800, Fernando de Oliveira wrote:
> > > 
> > > I intend to build the smallest that I can subset of gnome-3, just to get gnucash working, but not today or tomorrow. If it proves to need too many packages or too difficult, I will stick to gnome-2 (probably 2.30.2), as I do not need gnome, and do it just for that package. I have not yet started, though.
> > > 
[snip my initial response]

 Adding an 'executive summary' here, so people can decide if they
want to read the detail: I can build 2.4.10, but it crashes and is
therefore totally unusable.  See final paragraph if not reading the
rest.
> 
>  In the end, I took a look because I'd like to get rid of
> libgnomeprint{,ui} from the book: nasty, nasty, nasty - they support
> guile-1.6 and 1.8, but not 2.0 during this release (because they
> would have to drop 1.6 support).  Looking around, fedora have
> patches for this (9 for guile-2.0, from the gnucash list, a source
> file (engine-common.i), a 2.4.9-never-unload patch (these are all in
> gnucash-2.4.9-1.fc16 : I still can never manage to connect to
> fedora gitweb to look online), and a patch to stop it disabling
> icons when BUILDING_FROM_SVN is defined (dunno what that is about,
> but if it works for them...).  Also a 2.4.8 header fix that has
> already been applied to 2.4.10.
> 
>  So, apply the patches, cp engine-common.i src/engine,
> find src/quotes -name "*.in" -exec sed -i "s|use lib '@-PERLINCL-@';||g" {} \;
> 
> autoreconf
> export BUILDING_FROM_SVN=yes
> ./configure --prefix=/usr
> 
>  So far, I've confirmed that SLIB appears to not be needed with the
> patches (just as well, latest version apparently doesn't work with
> guile-2.0), but swig is required [ swig.org - I got 2.0.4, looks as
> if it would like to use boost (fat chance!) but builds ok without
> it.
> 
 On my not-gnome3 desktop, which already had the 'deprecated'
gnome-2 packages, I built swig, libunistring, gc, guile (2.0 series).
Then it needed gtkhtml >= 3.14.0 : gtkhtml-4, which will be going
into the book for gnome-3,, didn't suffice (probably installed a
different .pc file).

 Gtkhtml-3.30.2 is too old for the book's gtk2 or glib - too many
things are now deprecated.  In the end, I managed to build it with
 sed -i 's/-D.*DEPRECATED/ /' configure

 There are at least two separate deprecation issues, so its
anybody's guess whether the resulting build will ever be useful for
anything.

 On to gnucash-2.4.10.  The patch for is at
http://www.linuxfromscratch.org/~ken/misc-patches/gnucash-fedora-fixes

 Note the need for autoreconf, to be followed by the sed mentioned
in the patch.

 It also needs --enable-error-on-warning=no to avoid failing to
compile because of its own 'deprecated' messages.

 But, it crashes.  Complains it can't find the defaults (perhaps
that is normal on first run), takes me through the process, then
crashes.  Doing-it-myself, i.e. running update-gnucash-gconf in
another window, errors out.  After that, running gnucash produces a
small window in the middle of the screen for about half a second,
then it dies.  It gives a backtrace, but not in any form that I
understand.  It mentions a .scm file, so I guess it's a guile-2.0
issue.

 Note that it didn't need libgnomeprint, nor any obsolete gnome
packages which are not in the book's 'deprecated gnome' section.

 As I said in what I've snipped, it doesn't need slib with the
patch.

 It seems to me that no version of gnucash will be usable with the
current BLFS packages.  It probably needs an older gtk2/glib2, with
current slib and guile-1.8.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-dev mailing list