[blfs-dev] Git-1.7.9 issues

Andrew Benton b3nton at gmail.com
Fri Feb 17 16:55:47 PST 2012


On Fri, 17 Feb 2012 19:50:51 +0200
Thanos Baloukas <baloukasthan at sch.gr> wrote about git dependencies:

> ... zlib that is in LFS, it states ssh, Perl

Perl is also in LFS, ssh is a run time dependency.

> openssl, libcurl, expat, Tcl/Tk and gettext as dependencies.

gettext is in LFS, curl is a recommended dependency, Tk is listed as an
optional dependency, which leave openssl and expat.
I was thinking of openssl as a dependency of libcurl but it seems that
git can use it even without libcurl. I hadn't noticed expat is used by
git. Thanks for this. I'll add openssl and expat as optional
dependencies of git.

Andy



More information about the blfs-dev mailing list