[blfs-dev] Why is my message to this list being blocked?

Armin K. krejzi at email.com
Sat Feb 11 16:02:52 PST 2012


On 02/11/2012 11:55 PM, Ken Moffat wrote:
> On Sat, Feb 11, 2012 at 11:23:42PM +0100, Armin K. wrote:
>> On 11.2.2012 18:52, Ken Moffat wrote:
>>>    fcron works for me - what do you get from cronie that isn't
>>> available from fcron ?
>> Well, I like it's PAM and SELinux support.
>>
>   Hmm.  We don't do SELinux.

It's just my oppinion. I experiment with it.

>
>>>    Interesting.  I had been going to suggest (if I didn't already),
>>> half in jest, that libproxy could be dropped from the book since it
>>> is no longer required by the gnome packages and now uses that
>>> unpleasant replacement for configure.  Do you use it ?
>> I think glib-networking is only app that uses it now. (previously libsoup)
>>
>   But it's only optional there - at one time it was *required* for
> libsoup, and I believe that's why it went into the book.

Yeah, you're right! This is from glib-networking configure.

<http://www.linuxfromscratch.org/blfs/view/svn/basicnet/libsoup.html>checking 
for GLIB - version >= 2.29.18... yes (version 2.31.16)
checking for gio-querymodules... /usr/bin/gio-querymodules
checking for LIBPROXY... no
checking for GSETTINGS_DESKTOP_SCHEMAS... no
checking for GNUTLS... yes
checking for libgcrypt-config... /usr/bin/libgcrypt-config
checking for LIBGCRYPT - version >= 1.2.0... yes (1.5.0)
checking LIBGCRYPT API version... okay
checking location of system Certificate Authority list... 
/etc/ssl/certs/ca-certificates.crt

<output stripped>

   Proxy support: no
   TLS support:   gnutls
   TLS CA file:   /etc/ssl/certs/ca-certificates.crt

Yet libsoup depends on glib-networking and that one isn't even in the 
book. See for yourself: 
http://www.linuxfromscratch.org/blfs/view/svn/basicnet/libsoup.html

>
>> Yet there are not apps in book that use it, but there are apps that use
>> it! For example, pulseaudio programs - pavucontrol and paprefs.
>>
>   /me bites my tongue about a certain developers apps.  Perhaps they
> will have moved to the new versions by the time I look at them.
>> PulseAudio is a mess, I agree. But yet gnome 3 requires it to build and
>> even gnome mixer requires it to function. But for pulseaudio to work
>> properly I install alsa plugins package and create ~/.asoundrc or
>> /etc/asounrc to route all sound to pulseaudio.
>   Is that the mixer from gnome-media, or a different one ?  I know
> there is a working volume control in gnome-3, using pulse, but I've
> never managed to work out which package provides it.
>
>   Thanks for the comment on alsa-plugins - I haven't installed that
> for years - maybe that is why creating ~/.asoundrc didn't help when
> I tried to use pulse as an afterthought on top of a completed
> system.

Nah, gnome-media isn't yet ready for gnome 3 ... There is gtk+ 3 version 
only in git iirc. gnome-control-center provides volume applet and 
configuration through itself.

>>> ĸen, wishing he hadn't volunteered to be the gnome-3 monkey ;)
>> I've sucessfully built gnome 3.0, 3.2 and I am on my way building 3.4
>> (dev version). If I can help somehow, just say it!
>   Review of the updated packages, particularly the configure switches
> (Wayne has a lot of --sysconfdir, --libexecdir, --localstatedir,
> --mandir which are fine things to use when building for the first
> time, but shouldn't be in the book if they serve no purpose) is
> always useful.  Also, if you notice anything else that is wrong.

I see that many packages have --localstatedir=/var/lib ... Well, since 
scrollkeeper is old and not used anymore, that is wrong. Correct 
database path is now /var/lib/rarian, and it will get correctly 
installed if --localstatedir path is only /var ... Also, if you specify 
--disable-scrollkeeper, it won't do anything there.

Also, I don't know why many packages still use --prefix=$(pkg-config 
--variable=prefix ORBit-2.0) ... ORBit2 isn't even required for gnome 3.

Now, there is GNOME_SYSCONFDIR variable, but also all packages 
explicitly define --sysconfdir=/etc/gnome/3.2.2

--infodir isn't really needed for libgtop, since I don't even remember 
any gnome package installing .info files.

Neither --mandir is required in any of gnome packages since man pages 
are always installed in /usr/share/man

libgweather could use --enable-locations-compression to compress 
location files to save some space.

--libexecdir isn't required for control center.

libcanberra configure script mentions not to use oss where alsa is 
present. --disable-oss is recommended.

gstreamer base plugins have no need for ffmpeg.

eog is missing link to libpeas.

epiphany is missing link to seed. 
http://ftp.acc.umu.se/pub/gnome/sources/seed/ this is correct link by 
the way.

You can add link to book's network manager in gnome panel.

NetworkManager patch is a mess. It even creates some .c.orig files and 
yet so hard to read.

gdm doesn't ship gdm-{start,stop,restart,safe-restart} anymore

gnome mime data isn't really required for gnome 3.2 ...

There are gnome-applets for gnome 3 too ... Why are they in old desktop 
category?

libgnomecups, libgnomeprint, liboobs and system tools backends aren't 
required for gnome3. Yet you can move them into deprecated gnome packages

totem-pl-parser can use libquvi for link parsing.

gnome-accessibility doesn't apply for gnome3 ...

Yet there are only at-spi2-atk, at-spi2-core, and orca iirc.

These are some corrections I noted while just looking through the 
instructions.

>
> ĸen

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-dev/attachments/20120212/dbe1b123/attachment.html>


More information about the blfs-dev mailing list