[blfs-dev] Why is my message to this list being blocked?

Armin K. krejzi at email.com
Sat Feb 11 07:54:13 PST 2012


On 11.2.2012 15:53, Andrew Benton wrote:
> On Sat, 11 Feb 2012 15:15:00 +0100
> "Armin K."<krejzi at email.com>  wrote:
>
>> Now I tried again, but failed with same message from mail system. Here
>> is original mail:
>> Hello there. I have noticed lot of commits to blfs book lately. Good
>> job team, just keep it going! I wish I could help.
>>
>> Yet, I am unable to change anything directly, but here are few notes
>> that I've noticed when compiling some of packages.
>>
>> Please, don't attack me with "Why must that be so in the book" or
>> something like that. I just put this here as a reference.
>>
>> I know what are you guys like. You like minimal stuff and so, but yet
>> not everyone is like you and not everyone is skilled enough to find
>> everything he needs for something.
>>
>> So, let's start from the beginning of the book:
>>
>> Linux PAM can use libtirpc if someone wants to enable NIS support.
> I install PAM but I don't use NIS so I've never installed libtirpc. I
> can check this out and update the PAM dependencies in a day or 2
>
>> polkit does not require seperate user anymore as noted on
>> http://www.linuxfromscratch.org/blfs/view/svn/postlfs/polkit.html
>>
>> If you look at NEWS file in polkit source dir, you can notice this one:
>>
>> Changes since PolicyKit 0.94:
>>
>> David Zeuthen (20):
>>        Remove POLKIT_USER from configuration summary
>>
>> Michael Biebl (8):
>>        Remove POLKIT_USER option
>>
>> NOTE: This is just stripped output.
>>
>>
>> Old PolicyKit on
>> http://www.linuxfromscratch.org/blfs/view/svn/postlfs/policykit.html is
>> dead for some time and it has became polkit, it can be safely removed
>> from the book.
> I don't install
>
>> User notes on
>> http://www.linuxfromscratch.org/blfs/view/svn/postlfs/mdadm.html point
>> to http://wiki.linuxfromscratch.org/blfs/wiki/xfs Is this correct?
> I can fix that now.
>
>> The glib 2.30 compile will fail if dbus is not installed. (Though it's
>> only on gdbus tests iirc)
> Yes, dbus should be listed as an optional dependency to run the tests.
> I'll fix that now.
>
>> colord can use libsane. You can list it as optional.
>>
>>
>> ScrollKeeper from
>> http://www.linuxfromscratch.org/blfs/view/svn/general/scrollkeeper.html
>> isn't used anymore. Rarian package provides compatibility for it. It
>> can be removed.
> I agree, can we remove scrollkeeper please?
>
>> Besides fcron, you could add cronie from
>> https://fedorahosted.org/cronie/ which is in fact based on original
>> vixie cron but with some enhancments.
>>
>>
>> DBus GObject Bindings from
>> http://www.linuxfromscratch.org/blfs/view/svn/general/dbus-bindings.html#eggdbus
>> aren't used nor developed anymore. They can be safely removed.
> Good.
>
>> I note hal is still there, but yet many of software has been ported
>> from hal to gio/gvfs/gudev. Only package that I know that may use it is
>> gnome-vfs and yet hal is optional there.
> I've never used HAL and would also like to see it removed from the book.
>
>> UPower can also use libimobiledevice. You can add it as optional with
>> an external link to their site.
>>
>>
>> gvfs 1.10 can also use libimobiledevice and libbluray libraries. You
>> can add them as optional.
>>
>>
>> If you install python3.2 from
>> http://www.linuxfromscratch.org/blfs/view/svn/general/python3.html
>> first, you won't get /usr/bin/python, but /usr/bin/python3 ... Symlinks
>> can be made for it to be default.
>>
>>
>> Samba 3.6 will also fail to compile without libtirpc if using glibc
>> 2.14 or 2.15 ...
>>
>>
>> Avahi 0.6.28 (Why 0.28 when there is 0.6.30?) program avahi-autoipd
>> also requires seperate user avahi-autoipd with home
>> dir /var/lib/avahi-autoipd.
>>
>>
>> In libproxy 0.4.7 WebKit 1.0 library is required, not 3.0, so it would
>> be nice if mentioned.
>>
>>
>> As for Samba and Linux PAM, xinetd will also fail to compile using
>> glibc 2.14 or 2.15. Explicitly linking libtirpc with LDFLAGS=-ltirpc
>> solved that problem for me.
>>
>>
>> gtkmm has been updated to 3.x version, but same as for gtk 2.0 and gtk
>> 3.0, there may be need for gtkmm 3.0 and gtkmm 2.0 libraries which
>> don't conflict with each other.
>>
>>
>> Same for libwnck.
>>
>>
>> KDE4 section is a mess. Yet even required dependencies don't have links
>> to the packages in book.
>>
>>
>> Yet gnome pre installation configuration list
>> GNOME_SYSCONFDIR=/etc/gnome/3.2.2 even tough many packages have files
>> that should go into /etc (Yet every sane distribution and person list
>> only sysconfdir as /etc for every gnome package)
>>
>>
>> gstreamer bad plugins list kdebase dependency for kate, but yet there
>> is standalone libkate on http://code.google.com/p/libkate/ that doesn't
>> require bunch of qt3 stuff.
>>
>>
>> libdvdread 0.9.7 can't be used with gstreamer ugly plugins. Newer
>> version is required.
> Download link for newer version? I can only find an svn download from
> Mplayer
>
>> PulseAudio can also optionally use libasyncns and fftw
>>
>>
>> CUPS can use Avahi's libdns-sd compatibility library for DNS-SD
>> support. Note, there are also CUPS-AVAHI patches that link against
>> avahi libraries.
> Lots of interesting stuff there. Thanks for being persistent about
> sending it.
>
> Andy

http://dvdnav.mplayerhq.hu/#download

Both dvdread and dvdnav can be found there.



More information about the blfs-dev mailing list