[blfs-dev] [blfs-book] r9264 - trunk/BOOK/postlfs/security

Bruce Dubbs bruce.dubbs at gmail.com
Thu Feb 2 13:40:15 PST 2012


Andrew Benton wrote:
> On Thu, 02 Feb 2012 15:19:37 -0600
> Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
> 
>> andy at linuxfromscratch.org wrote:
>>> Author: andy
>>> +    <para><parameter>--disable-nis</parameter>: This option disables building
>>> +    Network Information Service/Yellow Pages support in pam_unix and pam_access
>>> +    as the needed headers files are no longer installed by glibc.</para>

>> Andy is this true?  LFS-7.0 has an errata that shows how to install the 
>> headers and LFS-svn does it in the book.  I'm not sure about libraries 
>> though.
>>
>> I admit that few users use nis any more and if the capability is needed 
>> at all, then the use of ldap is preferred.

> I may have been a bit hasty, I was not aware that the book now had
> instructions to copy the rpc headers by hand. I'll (or you can) revert
> the change if you want, but I think that we should install linux-PAM
> with --disable-nis because the functionality it depends on is
> deprecated in glibc so we can't rely on it being available in the
> future. Plus, as you say, few users use nis any more.
> I just think it's simpler this way.

Oh, I agree with the the setting.  I was just asking about the statement 
about needed headers not being installed.  I'd just suggest changing

   the needed headers files are no longer installed by glibc

to

   nis is deprecated in glibc.

   -- Bruce



More information about the blfs-dev mailing list