[blfs-dev] Problems with 7.2-rc1

Ken Moffat zarniwhoop at ntlworld.com
Mon Aug 27 20:50:56 PDT 2012


 Overall this is looking good.  I've still got a few things to build
(boost - apparently it will need to be upgraded for glibc-2.16.0),
gnash, and a little of xfce (for parole and xfburn).  Meanwhile, I
think the following might be worth noting:

1. polkit-0.107

 With parallel make, failed to find libpolkit-gobject-1.la in
temporary link.  Builds ok with make -j1.  Hopefully, the patch
for make will fix this as well as the webkit parallel build problem.

2. transcode-1.1.7

 Builds ok with the ffmpeg patch (thanks, Armin!) but has reduced
functionality.  In particular, anything which needs to use ffmpeg
does not work.  Still testing - it is usable to get the sound from
a DVD, and it managed to convert it to wav (in this example the
audio tracks are all ac3, which seems unusual).  Not sure if it is
able to do anything with the video files - might now need extra
libraries (e.g. libquicktime) because it can't use ffmpeg.

3. gcalctool-6.4.2.1 FTBFS

In file included from ./mp-equation-parser.y:20:0:
mp-equation-parser.h:154:25: error: unknown type name ‘yyscan_t’

 Using the development version 6.5.90.1, which has replaced the
lex/bison parser with a handwritten one, works (all the dependencies
are satisfied by the versions as are in the book for gnome-3.4).

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-dev mailing list