[blfs-dev] GNOME Support Libs

Randy McMurchy randy at linuxfromscratch.org
Mon Aug 20 14:52:57 PDT 2012


Armin K. wrote these words on 08/20/12 16:21 CST:

> Yes, I almost agree, but GNOME itself makes point releases, so it is 
> easier for person that upgrades from lets say 3.4.0 to 3.4.1 to upgrade 
> everything. The exception would be the fixes after official releases - 
> 3.4.1 was last official GNOME release, but some packages are at .4 
> already, so in that case you can create tickets if you like.

Where it gets sticky is a package like libcroco. It is a dependency of two
other packages in the book, gnome-shell and librsvg (required dependency in
both packages). However, librsvg is used in all kinds of stuff. So, what if
there is an update to libcroco? Do we not identify that and just let it go
until a GNOME update?

I think not. I think a ticket should be created, someone accept the ticket,
look at the changelog, consult this list if need be, and then update the
package. The BLFS GNOME maintainer could also update the package and see
if it breaks his installed copy of GNOME.

Does this procedure sound reasonable?

-- 
Randy

rmlscsi: [bogomips 1003.24] [GNU ld version 2.16.1] [gcc (GCC) 4.0.3]
[GNU C Library stable release version 2.3.6] [Linux 2.6.14.3 i686]
16:46:00 up 3:50, 1 user, load average: 0.06, 0.10, 0.09



More information about the blfs-dev mailing list