What D-Bus version should we target?

Randy McMurchy randy at linuxfromscratch.org
Tue Nov 9 18:27:29 PST 2010


Dan Nicholson wrote these words on 11/09/10 20:01 CST:
> The tight coupling between D-Bus and HAL should be gone. HAL is in
> compatibility mode and should work with any recent D-Bus. A lot of
> apps have moved away from HAL but it'll still be needed in spots.
> 
> I haven't looked closely at D-Bus in a while. It's become pretty
> stable over the years. You could definitely play it safe using 1.2.24
> since 1.4.0 has only been out a month or so.

Dan, thanks for your prompt and courteous reply. I will take into
consideration everything you said and probably update the book to
1.2.24 as you suggest. It's coincidence that I would have updated to
the most recent 1.2.x version if there was no input to my message, so
I suppose you and I are thinking alike.

Thanks for your input, it is really appreciated!

-- 
Randy

rmlscsi: [bogomips 1003.28] [GNU ld version 2.16.1] [gcc (GCC) 4.0.3]
[GNU C Library stable release version 2.3.6] [Linux 2.6.14.3 i686]
20:22:00 up 8 days, 3:16, 4 users, load average: 0.01, 0.00, 0.00



More information about the blfs-dev mailing list