Discussion about a new BLFS release

Robert Xu robxu9 at gmail.com
Thu Nov 4 15:46:57 PDT 2010


On Thu, Nov 4, 2010 at 18:04, Ken Moffat <ken at linuxfromscratch.org> wrote:
> On Thu, Nov 04, 2010 at 12:00:05PM -0400, Robert Xu wrote:
>> On Thu, Nov 4, 2010 at 09:57, Randy McMurchy <randy at linuxfromscratch.org> wrote:
>> >
>> > Sections 26-28: KDE
>> > Not even a clue what to do here. The book version is a more than two
>> > year old desktop that I don't even know if anyone has been following for
>> > security patches. Nobody likes CMake and KDE4.x (well, not really nobody,
>> > but there has been no book development towards it), so what to do?
>>
>> You know, I said I was going to put Trinity stuff for KDE, and I still
>> stand by it.
>> However, since I have absolutely no clue how to work the XML files
>> (and it'd make me lazy, lol), I'll throw everything into text files
>> and attach it.
>
>  Actually, from time to time they would make your head explode, and
> the xml is generally a lot *harder* than plain text.  Occasionally,
> the error messages just report that index.xml failed to validate in a
> non-existent line number).  But there is usually a way around -
> knowing exactly *what* you changed helps there.  More to the point,
> text is easier for most people to review and would be fine.
>>
>> For trinity, however, I'm going to require an old version of Autoconf, 2.63.
>> I can also post build directions for that (in /opt) when I get to that.
>>
>  Are you sure it needs an old version ?  I took a brief look at
> tqtinterface, copied in my installed libtool.m4 to
> admin/libtool.m4.in, and ltmain.sh to admin/ltmain.sh and then 'make
> -f admin/Makefile.common' _seemed_ to work adequately.  But that was
> as far as I went because I didn't have space or time to build qt4.

yes, it does require an old version.

>
>  It seems that it ought to build using qt4, because --enable-qt4
> appears to disable all qt3 support in tqtinterface, but confirmation
> would be nice.

well, that's broken atm. when cmake is implemented and we can get rid
of the old and dying stuff qt4 development will start.
tqtinterface defines all the functions that Trinity KDE uses; so when
it is ported to Qt4, nothing else in Trinity needs to change
since tqtinterface will provide all that.

>
>  And has anyone any links to upstream bugzilla or development ?
>

Me.

-- 
later, Robert Xu



More information about the blfs-dev mailing list