nfs-utils

Tobias Gasser lfs at ebp-gasser.ch
Tue Nov 2 02:26:07 PDT 2010


On Mon, 1 Nov 2010 00:55:48 -0700, treah blade <treah.blade at gmail.com>
wrote:
> I am unsure if anyone has been keeping an eye on this package as it is
> really a require package if you will be using nfs at all in your system.
> The version that currently is in blfs is 1.1.4 which at this point is
over
> 2 years old and now with the current version of LFS using a diffrent
glibc
> no longer builds cleanly. I understand that blfs does not always match
up
> with the current version of LFS but soon this pacakge will need to be
> updated in order to continue to be availiable.   One of the issues with
the
> newer build of this has diffrent requirements for dependancies then the
old
> version. 

the following steps are what i'm doing to have nfs up and running:

- tcp_wrappers 7.6 
  as in the blfs book

- portmap 6.0
  as in the blfs book

- libattr 2.4.44
  as in the blfs book

- libcap 2.19 (1.0.0 from book failed)
  sed 's at -lattr@"-L/usr/lib -lattr"@' libcap/Makefile
(i have no idea, why /usr/lib is not searched by default)
  make
  make prefix=/usr lib=lib install
  mv /usr/lib/security/pam_cap.so /lib/security

- libevent 1.4.14b
  configure --prefix=/usr
  make
  make install

- libnfsidmap 0.23
  configure --prefix=/usr
  make
  make install

- nfs-utils 1.2.3
  configure --disable-tirpc --disable-gss \
     --enable-nfsv3 --enable-nfsv4 --disable-nfsv41 \
     --enable-mount --with-tcp-wrappers
  make
  make install


i hope, this helps...

greetings
tobias





More information about the blfs-dev mailing list