"known to build with"

Ken Moffat zarniwhoop73 at googlemail.com
Fri Aug 6 14:35:10 PDT 2010


On 4 August 2010 23:32, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>
> I ran into the same thing with mysql.  Perhaps we need something like:
>
> <!ENTITY lfssvn_checked "<para>This package is known to build and work
> properly using an LFS-SVN-"
>
> <!ENTITY platform "platform.</para>">
>
>
> Then, in the page,
>
> &lfssvn_checked;20100804 &platform;
>
> Change the date as appropriate.
>
 I can't get that to pass the validation, the problem seems to be
(a) the entities are no longer a whole paragraph
(b) the bit in between (the date) isn't a recognised entity.
I've got it rendering (in test - I don't have any svn updates
at the moment, and I'm not sure which version you used for
mysql) with:

<!-- usage: <para>&lfssvn_checked;ccyymmdd platform.</para> -->
<!ENTITY lfssvn_checked       "This package is known to build and work properly
                               using an LFS-svn-">

 The 'platform' entity is redundant, but the result does render.

 Also, no _needs_update version for 6.6 (seems redundant),
and no _built version for svn (too much text needed with it, perhaps
another entity for "platform but has not been tested.".

 Those can be added if someone finds a use case.

 Will commit after I've taken a fresh look at the output.

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the blfs-dev mailing list