GNOME 2.26.3

DJ Lucas dj at linuxfromscratch.org
Wed Sep 23 22:13:24 PDT 2009


On 09/24/2009 12:02 AM, Sami Tarazi wrote:
> The following works for libproxy-0.2.3 and libproxy-0.30:
>
> mozjs_CFLAGS="-I/usr/lib/xulrunner-devel-1.9.1.2/include -DXP_UNIX \
> -DJS_THREADSAFE" ./configure --prefix=/usr
>
> following the argument in:
>
> "http://code.google.com/p/libproxy/issues/detail?id=18"
>
> it seems pkg-config does not look for mozilla-js as installed ny xulrunner.
>
> I am still building gnome and hope this works.
>
> Sami Tarazi
>    
Thanks Sami!  Maybe a note with the needed CLFLAGS will be sufficient in 
the command explanations section for libproxy.  If not, maybe I can fix 
the configure script and send upstream....been doing a lot of that 
lately. :-)  Some sort of AC check on $($PKG_CONFIG --modversion 
mozilla-js >= 1.9.1)" should be sufficient.  BTW, if anyone tries to fix 
it, don't put any weight on the syntax above, it's just an example, I am 
very weak in writing auto tool scripts.

-- DJ Lucas


-- 
This message has been scanned for viruses and
dangerous content, and is believed to be clean.




More information about the blfs-dev mailing list