GNOME 2.26.3

Sami Tarazi e44bpws at gmail.com
Wed Sep 23 22:02:01 PDT 2009


> Libproxy picks up mozjs support, but is not aware of stable/unstable
> include dirs in recent xulrunner.  I think --without-mozjs should be
> default with an explanation to remove it and prepend
> 'CFLAGS="-I/usr/include/xulrunner-&xulrunner-version;/unstable"
> LDFLAGS="--rpath-link
> -L/usr/lib/xulrunner-&xulrunner-version;-devel"...' to the make line.
>
> Warning:  I haven't tried the above and just opted for the
> --without-mozjs as javascript support in automated html browsing
> functions is something that I'll likely never need.
>
> -- DJ Lucas

The following works for libproxy-0.2.3 and libproxy-0.30:

mozjs_CFLAGS="-I/usr/lib/xulrunner-devel-1.9.1.2/include -DXP_UNIX \
-DJS_THREADSAFE" ./configure --prefix=/usr

following the argument in:

"http://code.google.com/p/libproxy/issues/detail?id=18"

it seems pkg-config does not look for mozilla-js as installed ny xulrunner.

I am still building gnome and hope this works.

Sami Tarazi



More information about the blfs-dev mailing list