openldap-2.4.16, db-4.5.20 and gdbm-1.8.3

Guy Dalziel krendoshazin at dementedfury.org
Sun Sep 20 12:55:10 PDT 2009


On Sun, Sep 20, 2009 at 10:21:26PM +0400, Sami Tarazi wrote:
> openldap-2.3.39 does not build and results in some errors with LFS 6.5.
> 
> openldap-2.4.16 compiles successfully provided that:
> 
>   --diable-ndb
>   CPPFLAGS=-D_GNU_SOURCE
> 
> are passed to configure, with db-4.5.20 or gdbm-1.83.  make test seems
> to proceed to end without errors with db-4.5.20

Sami, we currently have Berkeley DB 4.7.25 and OpenLDAP 2.4.12 in the
ticket system for upgrades. Recent reports would suggest that this
combination works, and I would suggest to try that version of BDB with
OpenLDAP 2.4.16. Hopefully the current instructions should work for them
but we will get around to upgrading them soon. We will likely use 2.4.16
as that is the latest stable, and unless there are any serious issues
with it then there's no reason to not put it in.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-dev/attachments/20090920/5aa87716/attachment.sig>


More information about the blfs-dev mailing list