Development BLFS and LFS

Philipp Christian Loewner bOrgph at web.de
Mon Sep 14 10:00:17 PDT 2009


Hi everyone!

I'm currently compiling a BLFS system using a brand new LFS (Development
Version). There were some problems I would like to report.

First of all, CyrusSASL doesn't compile with GCC4.4. There is a new version
available for download but as that didn't compile either I chose to stick
with the book's version and try to fix it.
I don't know how to make patches and the error is a preprocessor one so I
will just point out what worked for me, without guarantee that it will
work for any other machine.
I took the file plugins/digestmd5.c and changed the following lines:
line 2718 to #elif defined(WITH_DES)
line 4037 to #elif defined(WITH_DES)
That compiled fine.
I just looked it up in the mailing list archives and saw this issue has
already been discussed, but it still isn't changed in the book.

Second, x-cursor-themes is not available at the given ftp location any
more. The new location is:
ftp://ftp.x.org/pub/individual/data/xcursor-themes-1.0.1.tar.bz2


And third, KDE3 is no longer updated by the devs. I found two patches to
make kde-libs and kde-base work with GCC4.4, but as other kde packages
fail to build, too, I will try and migrate to KDE4.
I'm pretty sure you are aware of this problem, yet I haven't seen anything
about KDE on this list lately. As I'm going to keep a close eye on my
build anyway, I could provide you with some information that I gather if
that would help.
If that is the case, please tell me what information I should keep in
particular (build logs?, check logs? anything else?)
Oh, almost forgot that: The patches for KDE3 can be found here:
http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/kdebase/kdebase-gcc44.patch
http://cvs.pld-linux.org/cgi-bin/cvsweb.cgi/packages/kdelibs/kdelibs-gcc44.patch

   - Philipp



More information about the blfs-dev mailing list