Circular dependency with webkit in gnome-2.28 ?

Ken Moffat zarniwhoop73 at googlemail.com
Tue Oct 6 16:54:24 PDT 2009


I spent some time looking at the gnome-2.28 configure scripts,
and reworked my build order to what I thought might work.
Then I gave it a go.

Looking at libproxy, that can use webkit.  So, build
webkit before libproxy.  Failed, webkit needs libsoup.
Consult my script - libproxy is a dependency of libsoup.

Took a look at fc12 (they call it 'webkitgtk' there),
confirmed these are all labelled as build dependencies.

Will try building in the order libproxy, libsoup, webkit
but not sure if that means soem functionality will be
lost.  Ho hum.

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the blfs-dev mailing list