Compatibaly issues with libjpeg-7

William Immendorf will.immendorf at gmail.com
Sun Jul 26 07:32:27 PDT 2009


As libjpeg-7 has issues with KDE 3.5 and some older binary packages,
we need to build the libjpeg-62 shared libs and put them into
/usr/lib. Here's how:

   1. After installing libjpeg7, get libjpeg62 from
ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v6b.tar.gz (JIG dosen't have
libjpeg62, and this mirror has libjpeg62.)

   2. Then run ./configure --prefix=/usr --enable-shared --enable-static

   3. And then run make.

   4. Then run this command:

   cp -v .libs/libjpeg.so.* /usr/lib

And then you have the old libjpeg libs, just in case you're building
KDE or an older package that needs these libs.



More information about the blfs-dev mailing list