ruby 1.9 problem

Tobias Gasser lfs at ebp-gasser.ch
Sat Jul 25 16:13:22 PDT 2009


mod_ruby-1.3.0 states "supported ruby 1.9 experimentally"

building mod_ruby 1.3.0 with ruby 1.9.1-p129 and apache 2.2.11 does not
work here. apache segfaults.


anybody out there having this combination up and running??

or any patch for mod_ruby ??



i'm using ruby 1.8.7-p174 and mod_ruby 1.3.0.
this combination works fine here


eruby runs fine with those two packages when applying the patch from debian

you have to build
1.) ruby 1.8.7-p174
2.) eruby 1.0.5 with debian patch
3.) mod_ruby 1.3.0


http://modruby.net/en/index.rbx/mod_ruby/download.html
http://modruby.net/en/index.rbx/eruby/download.html
http://ftp.de.debian.org/debian/pool/main/e/eruby/eruby_1.0.5-2.diff.gz


tobias




More information about the blfs-dev mailing list