Annotating LFS-6.5 compatibility

Guy Dalziel krendoshazin at dementedfury.org
Sat Jul 25 12:37:21 PDT 2009


On Sat, Jul 25, 2009 at 02:22:18PM -0500, Randy McMurchy wrote:
> As BLFS packages are built on top of an LFS-6.5 system, insert the
> following between the description of the package and the sect3 "Package
> Information".
> 
> <para>This package is known to build and work properly using an LFS-6.5 platform.</para>

> Sound agreeable?

Well, I'm perfectly happy to do it if it clarifies the issue. I know it
will certainly be of use for packages that haven't had an update in a
long time, but were last checked against who knows what platform. Libmad
is a good example with -fforce-mem now being obsolete. It hasn't had an
update in about 5 years, but it would, if I remember correctly, have 
worked perfectly well on LFS 6.3.
I shall have to start writing these in once I get my 6.5 system up. I
built my current base before the switch to GCC 4.4.1, so I have 4.4.0 at
the moment. There shouldn't be much difference between the two, it's
just a bugfix release afterall, but I'll sort out any issues that arise
with the packages I've updated and put the note in.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-dev/attachments/20090725/41fe9b43/attachment.sig>


More information about the blfs-dev mailing list