gnome-vfs-2.18.1 compile error

DJ Lucas dj at linuxfromscratch.org
Mon Jul 20 08:26:50 PDT 2009


Craig Jackson wrote:
> Not sure if this is fixed upstream...
>
> Looks like the G_GNUC_FUNCTION macro is deprecated.  Here is the
> workaround I used to get it to compile:
>
> for f in `grep -H -r -s "G_GNUC_FUNCTION" * | cut -d: -f1`; do sed -i
> "s/G_GNUC_FUNCTION/G_STRFUNC/g" $f; done
>
> BLFS DEVS:  Please let me know if there is a better way (i.e. trac) to
> report on these type of issues.
>
> Thanks,
>
>   
Craig, as already mentioned, will probably be skipping a 6.4 release.  I 
know one other contributor, Wayne, was wanting to work on 
Gnome-2.26.{2,3}, as well  as myself, however, as gnome-2.18 will 
probably not be updated (as far as the book is concerned) the wiki would 
be the perfect place for items that will not be addressed by a 
'released' book (though a comment here is nice too).

Thanks.

-- DJ Lucas


-- 
This message has been scanned for viruses and
dangerous content, and is believed to be clean.




More information about the blfs-dev mailing list