Xorg lib problems

Aleksandar Kuktin akuktin at gmail.com
Sun Dec 20 11:25:41 PST 2009


>On Sat, 19 Dec 2009 11:34:14 -0900
>ALIP BUDIANTO <rabbit8888 at gmail.com> wrote:
>
> 
> On Dec 18, 2009, at 4:35 AM, Dan Nicholson wrote:
> 
> > On Fri, Dec 18, 2009 at 2:00 AM, treah blade
> > <treah.blade at gmail.com> wrote:
> >> On Thu, 17 Dec 2009 23:49:04 -0900
> >> ALIP BUDIANTO <rabbit8888 at gmail.com> wrote:
> >> 
> >>> SOmeone that made the wget list for the libs forgot to get the
> >>> deps orgainized and result is No package 'xtrans' found
> >>> 
> >>> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> >>> installed software in a non-standard prefix.
> >>> 
> >>> Alternatively, you may set the environment variables X11_CFLAGS
> >>> and X11_LIBS to avoid the need to call pkg-config.
> >>> See the pkg-config man page for more details.
> >>>  on libX11 and i dont even have time to just get the mail spell
> >>> checked or to manually install the libs --
> >>> http://linuxfromscratch.org/mailman/listinfo/blfs-dev
> >>> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> >>> Unsubscribe: See the above information page
> >> 
> >> Was that some sort of recent change because I am looking at the
> >> dev version of BLFS that I downloaded that is Version
> >> svn-20091125  and the wget list for the xlibs shows xtrans right
> >> at the top?
> > 
> > The change is to put $XORG_PREFIX/share/pkgconfig in
> > PKG_CONFIG_PATH, too. xtrans is arch-independent.
> > 
> > --
> > Dan
> > -- 
> > http://linuxfromscratch.org/mailman/listinfo/blfs-dev
> > FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> > Unsubscribe: See the above information page
> I did it, but it still does 
> checking for X11... configure: error: Package requirements (xextproto
> xtrans xcb >= 1.1.92) were not met:
> 
> No package 'xtrans' found
> 
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
> 
> Alternatively, you may set the environment variables X11_CFLAGS
> and X11_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> 
> and it installed xtrans and i think is installed xextproto and xcb
> arleady.

xtrans is among the first libraries that have to be installed.

So, build it as the first library and then go for the rest.
Take note that there are other dependencies among the libraries.
This order works for me (Xorg-7.5):

libXau
xtrans
libpthread-stubs #downloaded separately
libxcb #downloaded separately
libX11
libFS
libICE
libSM
libXext
libXt
libXmu
libXpm
libXaw
libXfixes
libXcomposite
libXrender
libXcursor
libXdamage
libXdmcp
libfontenc
libXfont
libXft
libXi
libXrandr
libXres
libXtst
libXv
libXvMC
libXxf86dga
libXxf86vm
libdmx
libpciaccess
libxkbfile
libXScrnSaver
libXinerama



More information about the blfs-dev mailing list