Thunderbird

treah blade treah.blade at gmail.com
Tue Dec 8 13:27:25 PST 2009


On Mon, 07 Dec 2009 23:58:14 -0600
DJ Lucas <dj at linuxfromscratch.org> wrote:

> On 12/07/2009 11:11 PM, Treah Blade wrote:
> > The current version of thunderbird is 2.0.0.23 the one included in the 
> > blfs dev is 2.0.0.12 this is 11 revisions back and the current one 
> > includes many bug fixes and many security fixes. I understand that you 
> > need time to test new versions to make sure they work alright. The 
> > problem here is that 2.0.0.12 does not compile cleanly when you use 
> > the dev version of LFS and the dev version of BLFS. It fails to 
> > compile unless you apply a patch to fix a source file or use work 
> > arounds in the .mozconfig.  You may wanna update the version that is 
> > in the dev book.
> 
> Nor is 2.0.0.12+ usable in TWM (or probably anything other than a Gnome 
> environment).  We are pretty much stuck.  I think .11 provided correctly 
> sized dialogs when patched, but I'm not sure as it's been a while since 
> I messed with it.  Since the 3x betas are running great, I decided to 
> wait until the 3.0 release.
> 
> Note that you will not be able to build against a system XUL for 
> TB3...specifically problems with mozab, glue, and ldap.  Sorry, not 
> about to try and hack up XUL specifically for mozab because we'd be too 
> far out from upstream, nor do I honestly know how to pull in the needed 
> sub-projects.  I'm not exactly sure how this is going to pan out for OOo 
> address book integration as I haven't even began to look at OOo-3 yet.
> 
> -- DJ Lucas
> 
> 
> -- 
> This message has been scanned for viruses and
> dangerous content, and is believed to be clean.
> 
> -- 
> http://linuxfromscratch.org/mailman/listinfo/blfs-dev
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page


-- 
treah blade <treah.blade at gmail.com>

I just attempted to compile it again after fixing the source file for nsAppRunner.cpp and doing the .mozconfig workaround for another compiler error and now im getting a message about something missing in its security. I gave up trying to get it installed its severally broken when trying to use gcc 4.4.2 I just compiled sylpheed 2.7.1 for now and its working great :P.  Thank you for responding and if anyone has any idea how to integrate sylpheed into icewm let me know. I attempted it but only succeeded in making a red mailbox icon :) 



More information about the blfs-dev mailing list