Trouble configuring xorg on a 64-bit system

Bruce Dubbs bruce.dubbs at gmail.com
Mon Aug 31 11:39:00 PDT 2009


Dan Nicholson wrote:

> Yeah, that's the one. If I recall, this FATAL is not really the one
> bringing down X. Ah, now I remember. The "FATAL: Module fbcon not
> found" is actually coming from modprobe since you have fbcon built in
> and it can't find a loadable fbcon module. It's not actually fatal to
> X since the module is loaded (and X wouldn't need it anyway). There's
> gotta be a different error there, so I think we'd need to look at the
> X log.

I can't get the i915 log unless I remove th nvidia card.  I'm not sure this is 
worth trouble shooting.  It isn't to me, but if you want me to, I'll do it.

> This is an Intel G45 or something? What type of monitor and connection
> are you driving? 

(--) NVIDIA(0): --- EDID for DELL IN1910N (CRT-1) ---
(--) NVIDIA(0): EDID Version                 : 1.3
(--) NVIDIA(0): Manufacturer                 : DEL
(--) NVIDIA(0): Monitor Name                 : DELL IN1910N
(--) NVIDIA(0): Product ID                   : 41036
(--) NVIDIA(0): 32-bit Serial Number         : 911625043
(--) NVIDIA(0): Serial Number String         : J349N96N6VKS
(--) NVIDIA(0): Manufacture Date             : 2009, week 26
(--) NVIDIA(0): DPMS Capabilities            : Standby Suspend Active Off
(--) NVIDIA(0): Prefer first detailed timing : Yes
(--) NVIDIA(0): Supports GTF                 : No
(--) NVIDIA(0): Maximum Image Size           : 410mm x 230mm
(--) NVIDIA(0): Valid HSync Range            : 30.0 kHz - 83.0 kHz
(--) NVIDIA(0): Valid VRefresh Range         : 56 Hz - 75 Hz
(--) NVIDIA(0): EDID maximum pixel clock     : 90.0 MHz

(--) NVIDIA(0): Detailed Timings:
(--) NVIDIA(0):   1366 x 768  @ 60 Hz
(--) NVIDIA(0):     Pixel Clock      : 85.50 MHz
(--) NVIDIA(0):     HRes, HSyncStart : 1366, 1436
(--) NVIDIA(0):     HSyncEnd, HTotal : 1579, 1792
(--) NVIDIA(0):     VRes, VSyncStart : 768, 771
(--) NVIDIA(0):     VSyncEnd, VTotal : 774, 798
(--) NVIDIA(0):     H/V Polarity     : +/+

It's a flat panel, but it uses a standard 15-pin VGA connection.

> If I had to take a guess, I would say that KMS is
> failing for you. They're still working some of the bugs out to get KMS
> up to the standard of the userspace modesetting from xf86-video-intel.
> In that case, the options are to boot with i915.modeset=0 or try newer
> kernels to see if things are fixed. Of course, whether you want to
> pursue or not is up to you since you've got working nvidia graphics.

I don't know what KMS is.  The system is a stock LFS-6.5 with a 2.6.30.2 kernel. 
  I don't know how fast they develop.  If you mean Keyboard-Mouse-System,  what 
I have now is:

(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' 
will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0

and later:

(**) USB Optical Mouse: always reports core events
(**) USB Optical Mouse: Device: "/dev/input/event3"
(II) USB Optical Mouse: Found 3 mouse buttons
(II) USB Optical Mouse: Found x and y relative axes
(II) USB Optical Mouse: Found scroll wheel(s)
(II) USB Optical Mouse: Configuring as mouse
(**) USB Optical Mouse: YAxisMapping: buttons 4 and 5
(**) USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, 
EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Optical Mouse" (type: MOUSE)
(**) USB Optical Mouse: (accel) keeping acceleration scheme 1
(**) USB Optical Mouse: (accel) filter chain progression: 2.00
(**) USB Optical Mouse: (accel) filter stage 0: 20.00 ms
(**) USB Optical Mouse: (accel) set acceleration profile 0
(II) USB Optical Mouse: initialized for relative axes.
(II) config/hal: Adding input device Dell Dell QuietKey Keyboard
(**) Dell Dell QuietKey Keyboard: always reports core events
(**) Dell Dell QuietKey Keyboard: Device: "/dev/input/event2"
(II) Dell Dell QuietKey Keyboard: Found keys
(II) Dell Dell QuietKey Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "Dell Dell QuietKey Keyboard" (type: 
KEYBOARD)

One thing to mention is that the problem I saw on the graphics screen was a 
completely black background and no X cursor when I did:

Xorg -config /root/xorg.conf.new

Now that I think about it, I think I saw the same thing with the nvidia card 
(but no FATAL message).  I then tried startx and it worked.  It's possible that 
trying startx with the i915 driver might have worked, but I never tried it.

   -- Bruce




More information about the blfs-dev mailing list