blfs-dev Digest, Vol 1425, Issue 1

Johan johanendea at orange.nl
Wed Jul 16 01:45:27 PDT 2008


please no messages back. for me is great problem, thanks for your help.
----- Original Message -----
From: <blfs-dev-request at linuxfromscratch.org>
To: <blfs-dev at linuxfromscratch.org>
Sent: Wednesday, July 16, 2008 8:00 AM
Subject: blfs-dev Digest, Vol 1425, Issue 1


> Send blfs-dev mailing list submissions to
> blfs-dev at linuxfromscratch.org
>
> To subscribe or unsubscribe via the World Wide Web, visit
> http://linuxfromscratch.org/mailman/listinfo/blfs-dev
> or, via email, send a message with subject or body 'help' to
> blfs-dev-request at linuxfromscratch.org
>
> You can reach the person managing the list at
> blfs-dev-owner at linuxfromscratch.org
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of blfs-dev digest..."
>
>
> Today's Topics:
>
>    1. dbus version mismatch (Guy Dalziel)
>    2. Re: dbus version mismatch (Dan Nicholson)
>    3. Re: dbus version mismatch (Guy Dalziel)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Tue, 15 Jul 2008 11:18:39 +0100
> From: Guy Dalziel <krendoshazin at gmail.com>
> Subject: dbus version mismatch
> To: BLFS Development List <blfs-dev at linuxfromscratch.org>
> Message-ID: <487C797F.10209 at gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Recently when trying to compile dbus-glib, a dependency of HAL, I was
> met with the error 'configure: error: DBus development libraries not
> found'. Review of the configuration file revealed that it is in fact
> looking for a version of dbus version 1.1 or better;
> line 26663: { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists
> --print-errors \"dbus-1 >= 1.1\"") >&5
>
> checking this with pkg-config gives:
>  pkg-config --exists --print-errors 'dbus-1 >= 1.1'
>  Requested 'dbus-1 >= 1.1' but version of dbus is 1.0.2
>
> and attempting to change the configuration file to 1.0 results with
> ./.libs/libdbus-glib-1.so: undefined reference to `dbus_watch_get_unix_fd'
>
> It will be necessary to upgrade dbus to >= 1.1 in order to get dbus-glib
> to work.
>
>
> ------------------------------
>
> Message: 2
> Date: Tue, 15 Jul 2008 05:45:24 -0700
> From: "Dan Nicholson" <dbn.lists at gmail.com>
> Subject: Re: dbus version mismatch
> To: "BLFS Development List" <blfs-dev at linuxfromscratch.org>
> Message-ID:
> <91705d080807150545l5956ade1j783a3c8cfcffb91 at mail.gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1
>
> On Tue, Jul 15, 2008 at 3:18 AM, Guy Dalziel <krendoshazin at gmail.com>
wrote:
> > Recently when trying to compile dbus-glib, a dependency of HAL, I was
> > met with the error 'configure: error: DBus development libraries not
> > found'. Review of the configuration file revealed that it is in fact
> > looking for a version of dbus version 1.1 or better;
> > line 26663: { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists
> > --print-errors \"dbus-1 >= 1.1\"") >&5
> >
> > checking this with pkg-config gives:
> >  pkg-config --exists --print-errors 'dbus-1 >= 1.1'
> >  Requested 'dbus-1 >= 1.1' but version of dbus is 1.0.2
> >
> > and attempting to change the configuration file to 1.0 results with
> > ./.libs/libdbus-glib-1.so: undefined reference to
`dbus_watch_get_unix_fd'
>
> There's a reason why they're specifying that version 1.1 is needed. :)
>
> > It will be necessary to upgrade dbus to >= 1.1 in order to get dbus-glib
> > to work.
>
> What version of dbus-glib are you trying to build? The one that's
> currently in the book certainly works with dbus-1.0.2.
>
> http://www.linuxfromscratch.org/blfs/view/svn/general/dbus-bindings.html
>
> --
> Dan
>
>
> ------------------------------
>
> Message: 3
> Date: Tue, 15 Jul 2008 15:51:50 +0100
> From: Guy Dalziel <krendoshazin at gmail.com>
> Subject: Re: dbus version mismatch
> To: BLFS Development List <blfs-dev at linuxfromscratch.org>
> Message-ID: <487CB986.5010501 at gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Dan Nicholson wrote:
> > What version of dbus-glib are you trying to build? The one that's
> > currently in the book certainly works with dbus-1.0.2.
> Nevermind, in my haste I managed to grab 0.76 somehow instead of 0.74.
> Perhaps this will at least serve as a future note to the need to upgrade.
>
>
> ------------------------------
>
> --
> http://linuxfromscratch.org/mailman/listinfo/blfs-dev
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page
>
> End of blfs-dev Digest, Vol 1425, Issue 1
> *****************************************
>
>
>
> --
> No virus found in this incoming message.
> Checked by AVG.
> Version: 7.5.524 / Virus Database: 270.4.11/1554 - Release Date: 15-7-2008
18:03
>





More information about the blfs-dev mailing list