dbus version mismatch

Guy Dalziel krendoshazin at gmail.com
Tue Jul 15 03:18:39 PDT 2008


Recently when trying to compile dbus-glib, a dependency of HAL, I was 
met with the error 'configure: error: DBus development libraries not 
found'. Review of the configuration file revealed that it is in fact 
looking for a version of dbus version 1.1 or better;
line 26663: { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists 
--print-errors \"dbus-1 >= 1.1\"") >&5

checking this with pkg-config gives:
 pkg-config --exists --print-errors 'dbus-1 >= 1.1' 
 Requested 'dbus-1 >= 1.1' but version of dbus is 1.0.2

and attempting to change the configuration file to 1.0 results with 
./.libs/libdbus-glib-1.so: undefined reference to `dbus_watch_get_unix_fd'

It will be necessary to upgrade dbus to >= 1.1 in order to get dbus-glib 
to work.



More information about the blfs-dev mailing list