GnuCash 2.2.2 has some Perl requirements

Kevin Buckley kevin.m.buckley at gmail.com
Sun Jan 13 14:38:15 PST 2008


I have recently found that although I was able to INSTALL GnuCash 2.2.2
by adding a couple of packages to the "minimal Gnome" I detailed on
here a while back, vis:

  http://wiki.linuxfromscratch.org/blfs/wiki/GNOMEDevPlatform

(The extra packages that allowed me to INSTALL (but not use) 2.2.2 were:

Goffice
libgsf
PCRE
)

however, the application bombs out when one tries to do anything
with the Scheduled Transaction editor .

Running a "follow the children" strace suggests that you need the
following Perl stuff as well:

write(2, "\n", 1)                       = 1
write(2, "You need to install the followin"..., 48) = 48
write(2, "  Finance::Quote\n", 17)      = 17
write(2, "  LWP\n", 6)                  = 6
write(2, "  HTML::Parser\n", 15)        = 15
write(2, "  HTML::TableExtract\n", 21)  = 21
write(2, "  Crypt::SSLeay\n", 16)       = 16
write(2, "  Date::Manip\n", 14)         = 14
write(2, "\n", 1)                       = 1
write(2, "Use your system\'s package manage"..., 51) = 51
write(2, "or run \'gnc-fq-update\' as root.\n", 32) = 32
write(1, "missing-lib\n", 12)                                  = 12

and indeed the script mentioned there tries to do a Perl CPAN install
of those modules.

I can't recall (nor work out as yet)  if the package requirement chain that
one would follow for GnuCash 2 would highight this so it might be worth
flagging it up explicitly.

FWIW, I had installed GnCash 2.0.1 using just the basic GnomeDEV environment
above.

Hope this is useful,
Kevin



More information about the blfs-dev mailing list