libusb and usbutils

Bruce Dubbs bruce.dubbs at gmail.com
Mon Dec 29 09:03:55 PST 2008


Matthew Burgess wrote:
> On Mon, 29 Dec 2008 02:14:14 -0600, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>> We have a problem with libusb and usbutils.
>>
>> libusb has released 1.0.0 on 2008-12-13.
>> usbutils is at version 0.73 released on 2007-10-24.
>>
>> 1.  Just leave out usbutils for now.
>> 2.  Revert to the earlier version of libusb.
>> 3.  Try to hack usbutils to use the new libusb.  Looking at the code, this
>> is
>> non-trivial and I don't have the time or inclination to do it.
>> 4.  Try to install both the old and new versions simultaneously.
>> 5.  There is a libusb-compat-0.1 compatibility layer.  It aims to look,
>> feel and
>> behave exactly like libusb-0.1. As it is a replacement, you cannot install
>> it
>> alongside libusb-0.1 on the same system.
>>
> 
> FWIW, I went with 5) when I stumbled across this, and haven't had any issues
> with it.  If/when the other packages are updated to work with the latest
> version of libusb's API, it then becomes a simple job of just removing the
> compatibility package from the book.
> 
> (ccing blfs-dev, please post follow-ups there).

Thanks Matt.  The initial post was obviously posted to the wrong list.

I have *got* to stop working so late...

   -- Bruce



More information about the blfs-dev mailing list