tcl/tk

Randy McMurchy randy at linuxfromscratch.org
Fri Dec 26 16:19:02 PST 2008


Bruce Dubbs wrote:
> After I updated tcl today, I started to look at tk and noticed that both tcl and 
> tk have updated to 8.5.6 as of December 23.
> 
> Question: Do we upgrade to 8.5.6 in blfs or stay or 8.5.5 to be consistent with 
> LFS 6.4?
> 
> The differences between 8.5.6 and 8.5.5 appear to be some bugfixes, but the 
> change log does not indicate anything really major.
> 
> I'm leaning toward staying with 8.5.5 but would like to hear other opinions.

This has always been an issue that comes up from time to time.
Last time, it was Matthew asking about it and the answer I'm
about to give, Matthew agreed with.

For Tk/Tcl I think it is okay to move forward with newer versions
because Tk/Tcl is not installed in Chapter 6 of LFS. Therefore,
if you follow LFS by-the-book, Tcl/Tk won't be installed when you
begin with BLFS.

For that reason, I think it is acceptable to go with the latest
release, providing it works with the Expect/DejaVu stuff.

You can search the archives for this subject and find the
discussion Matt and I had not too long ago (sigh... not to long
ago might be a year or more - time flies)

HTH.

-- 
Randy




More information about the blfs-dev mailing list