Xorg-server and evdev driver

Nathan Coulson conathan at gmail.com
Tue Dec 9 11:25:48 PST 2008


On Tue, Dec 9, 2008 at 9:14 AM, Dan Nicholson <dbn.lists at gmail.com> wrote:
> On Tue, Dec 9, 2008 at 12:22 AM, DJ Lucas <dj at linuxfromscratch.org> wrote:
>> DJ Lucas wrote:
>>> Guys..got a little issue with xorg and the evdev driver in Gnome.  I
>>> have a Logitech keyboard (standard 105 US layout + multimedia keys with
>>> function lock).  This issue has been reported several times as evidence
>>> shown by Google.
>>>
>>>
>> Scratch that, the proposed fix does not work...still investigating.  I
>> do not see all of the issues mentioned in those threads, but I do see a
>> few of them... up arrow key does not work and invokes the gnome
>> screenshot, Alt+F2 does bring up the run dialog box as expected, after I
>> return from console 2, Ctrl+C sends Ctrl+Alt+Bksp (interesting), oh so
>> fun...OTOH, it just works with the kbd driver as opposed to evdev.
>> There are reports that KDE has some of the same problems.  More tomorrow.
>
> Wrong keyboard buttons usually point to xkeyboard-config missing. When
> you use evdev for the keyboard, how are you configuring it? What
> version of evdev are you using? Is the server HAL enabled? Can you
> post the log?


I have had simular problems with my experiments in the Xorg-server-1.6
branch, (I just assumed it was me). Running xsetkbd w/ no parameters(I
may have this command wrong, not at my trusty linux system) fixed it
for the session in question though. *shrug*


-- 
Nathan Coulson (conathan)
------
Location: Brittish Columbia, Canada
Timezone: PST (-8)
Webpage: http://www.nathancoulson.com



More information about the blfs-dev mailing list