RPM

Bruce Dubbs bruce.dubbs at gmail.com
Mon Apr 21 20:56:24 PDT 2008


I would like to add RPM to BLFS because it is required for a system to be 
compliant with the Linux Standards Base.  It doesn't have to be for 6.3, but it 
is relatively easy.  The install issues:

Requires  beecrypt (CMMI)
RPM is basically CMMI, but needs --without-selinux for LFS
The install puts one file, rpm, in /bin instead of /usr/bin.  This is dumb 
because it requires libraries in /usr/lib.  (Yes, it is that way in RHEL.) I 
would move it to /usr/bin.

I do want to report on the Linux Collaboration Conference I went to a couple of 
weeks ago, but I haven't had time to write up my notes yet.  In any case, I 
think being LSB compliant would be relatively easy for us.  It would just 
require a few more packages, but I haven't compiled a full list yet.

   -- Bruce





More information about the blfs-dev mailing list