Gnome 2.18 problem

Randy McMurchy randy at linuxfromscratch.org
Sat Jul 28 06:18:03 PDT 2007


David Barron wrote:

> First the comment.  The libgnome-2.18.0 package lists EsounD-0.2.37 as 
> an optional dependency.  But when I ran the configure step just as it's 
> shown it balked at esound and audiofile not being installed.  So 
> shouldn't it be a required depenedency?

Thanks for the report. However, (I cannot look at sources right
now, so I can't be sure) I think you need to pass a parameter to
the configure command if ESoundD is not installed. One way or the
other, when I get back to my development computer, I'll do what
it takes to fix it. Unless another Editor beats me to it. :-)


> Second the problem.  I've gotten to libgnomekbd-2.18.2 and it's failing 
> during the build.  First, my XOrg 7.2 is installed to /opt/xorg-7.2 and 
> I'm installing Gnome to /opt/gnome-2.18.3.  During the build I get:

I'm thinking that we (well, most of the developers) are just being
hard-headed by not including a /usr/X11R6 symlink to the installed
location of Xorg. It makes things so much easier down the road after
X is installed. I realize that you can do without it, by using
workarounds, CFLAGS, whatever, but that just seems like a hassle to
avoid creating a symlink. To each his own, I suppose.

-- 
Randy




More information about the blfs-dev mailing list