Stuck on gnome 2.18 - gnome-vfs

Randy McMurchy randy at linuxfromscratch.org
Fri Jul 27 10:58:27 PDT 2007


Randy McMurchy wrote these words on 07/27/07 12:27 CST:

> Looking at the dependencies for GNOME VFS, I missed adding the
> dbus-glib package to the required section.

This is really bothering me. I think the biggest thing that BLFS
provides is the dependency lists. I carefully scan configure.{in,ac}
for each package. I suppose when I saw this:

if test "$ENABLE_HAL" = "yes"; then
        PKG_CHECK_MODULES(HAL, hal >= 0.5.7,
                [ USE_HAL="hal >= 0.5.7, hal-storage >= 0.5.7, dbus-1 >= 0.32, dbus-glib-1 >= 0.32"
                  AC_DEFINE(USE_HAL, 1, [defined if using libhal])
                  msg_hal=yes],
                [ USE_HAL=""])
else
        USE_HAL=""
fi

in my mind this made dbus optional. Only problem is I overlooked this:

PKG_CHECK_MODULES(LIBGNOMEVFS, glib-2.0 >= $GLIB_REQUIRED gmodule-no-export-2.0 >= $GLIB_REQUIRED gthread-2.0 >= $GLIB_REQUIRED gobject-2.0 >= $GLIB_REQUIRED gconf-2.0 >= $GCONF_REQUIRED libxml-2.0 >= $XML_REQUIRED gnome-mime-data-2.0 $dbus_requirement)

and I just don't know how I missed the dbus requirement. I hope
this hasn't happened in other places down the road. I suppose now
I need to go in and rip out all the D-Bus optional dependencies in
other packages that require GNOME VFS.

Sigh....

-- 
Randy

rmlscsi: [bogomips 1003.23] [GNU ld version 2.16.1] [gcc (GCC) 4.0.3]
[GNU C Library stable release version 2.3.6] [Linux 2.6.14.3 i686]
12:52:00 up 15 days, 5:59, 1 user, load average: 0.02, 0.06, 0.07



More information about the blfs-dev mailing list