gstreamer plugins good

Randy McMurchy randy at linuxfromscratch.org
Fri Aug 31 07:11:11 PDT 2007


[cc'd to blfs-dev]

Dan Nicholson wrote:

> I think that's true (if you're using the gstreamer backend and not the
> xine backend in totem). We should probably check that `gst-inspect
> gconfelements' returns successfully for totem. Or just Recommend the
> GConf dependency in gst-plugins-good since I'm pretty sure most of the
> gstreamer using GNOME apps leverage these plugins.

IMO recommending GConf for gst-plugins-good because Totem can
use it is a bit much. However, I think that if we put "(required
if you plan to install Totem using the GStreamer backend)" after
the GConf dependency, it would give enough information.

That way if someone doesn't install GConf before gst-plugins-good,
at least we documented the requirement.

Additionally, Totem should probably have a short para after the
dependencies saying that the GStreamer backend is the default now,
and you must ensure gst-plugins-good was built with GConf support
(use gst-inspect gconfelements to test).

-- 
Randy



More information about the blfs-dev mailing list