Why all these new packages?

Dan Nicholson dbn.lists at gmail.com
Thu Aug 16 16:22:08 PDT 2007


On 8/16/07, Randy McMurchy <randy at linuxfromscratch.org> wrote:
>
> 1. I saw this monstrosity (that I put in the book) in the dependencies
>    for kdepim:
>
>    GPGME (requires Libgcrypt-1.2.4 then Pth-2.0.7 then Libassuan-1.0.2 then
>     Libksba, pinentry, OpenSC and then GnuPG-1.9.x)
...
> 3. Sooner or later we'll probably move to GnuPG-2.x. When we do, all
>    the packages I'm putting in the book will be required. So may as well
>    do it, while it's fresh in my mind and I have time and motivation.
>
>
> Thoughts from others? Am I wasting my time?

In my experience, it seems that both 1.4 and 2.x are needed as some
utilities (like Enigmail) want to use the old interface. But gpgme
wants 2.x.

--
Dan



More information about the blfs-dev mailing list