Missing upstream Mplayer-1.0rc1 patch?

Randy McMurchy randy at linuxfromscratch.org
Thu Aug 16 13:44:33 PDT 2007


M.Canales.es wrote these words on 08/16/07 15:29 CST:

> If you say me the proper configure options to build against installed FFmpeg, 
> I will build now Mplayer with that patch applied and test how it work with 
> "good" videos and "broken" videos.
> 
> If all go well, I can do the update.

Here's the entire configure command I used
(the parms for FFmpeg are below this):

./configure --prefix=/usr \
            --confdir=/etc/mplayer \
            --with-extraincdir=/usr/include/ffmpeg \
            --with-codecsdir=/usr/lib/mplayer/codecs \
            --with-livelibdir=/usr/lib/live \
            --enable-gui \
            --enable-largefiles \
            --enable-menu \
            --disable-libavutil \
            --disable-libavcodec \
            --disable-libavformat \
            --disable-libpostproc \
            --enable-libavutil_so \
            --enable-libavcodec_so \
            --enable-libavformat_so \
            --enable-libpostproc_so \
            --enable-bl \
            --enable-xmms \
            --enable-xvmc \
            --with-xvmclib=XvMCW \
            --enable-dynamic-plugins


Just for external FFmpeg you would need:

            --with-extraincdir=/usr/include/ffmpeg \
            --disable-libavutil \
            --disable-libavcodec \
            --disable-libavformat \
            --disable-libpostproc \
            --enable-libavutil_so \
            --enable-libavcodec_so \
            --enable-libavformat_so \
            --enable-libpostproc_so \

Thanks Manuel!

-- 
Randy

rmlscsi: [bogomips 1003.27] [GNU ld version 2.16.1] [gcc (GCC) 4.0.3]
[GNU C Library stable release version 2.3.6] [Linux 2.6.14.3 i686]
15:41:00 up 3:54, 1 user, load average: 0.16, 0.13, 0.07



More information about the blfs-dev mailing list