Gnome-Python [Was Re: r7032 - in trunk/BOOK: general/sysutils gnome/add gnome/core]

Dan Nicholson dbn.lists at gmail.com
Wed Aug 8 11:01:12 PDT 2007


On 8/8/07, randy at linuxfromscratch.org <randy at linuxfromscratch.org> wrote:
> Log:
> Modified the Gnome-Python dependency list entity (use this until Gnome-Python is put in the book)

What's the plan for gnome-python? I think pygtk should definitely be
in the book. For gnome-python and gnome-python-desktop, I think it
will be a good idea if we attempt to enumerate them by module so that
people can attempt to avoid some extreme dependency hell.

gnome-python:
Required: pygtk and libgnome
Required (for gnome.ui module): pyorbit and libgnomeui
Required (for gnome.canvas module): libgnomecanvas
Required (for gnomevfs module): gnome-vfs
...

Then, for GNOME Applets, for instance (not necessarily true):
<xref linkend="gnome-python"/> (gnomevfs module), <xref
linkend="gnome-python-desktop/> (gnomeprint module)

What do you think? The configure.ac's for gnome-python and
gnome-python-desktop are fairly clear on what's needed for what
module. There might be a couple tricky ones, but I think we can get it
fairly correct.

--
Dan



More information about the blfs-dev mailing list