Dead Project? (I hope not)

Joe Ciccone jciccone at gmail.com
Sat Aug 19 12:12:34 PDT 2006


Dan Nicholson wrote:
>
>>
>>
>> The openat patch really only applies if you're building glibc with
>> --enable-kernel=2.6.17. (uses 2.6.0 currently.) So It doesn't need to be
>> added, Just mentioning it for the people that may want to.
>> http://www.linuxfromscratch.org/patches/downloads/glibc/glibc-2.4-openat-3.patch
>>
>
> Thanks, Joe. Question about the second one. It's different than the
> hack the guy proposes in the glibc bugzilla. How did you come up with
> what's there now?
What is in that patch is a combo of what Jim and myself came up with.
The last chunk in that patch is what I have to my name which ultimatly
fixes the build issue that showed up on mips
(http://pastebin.cross-lfs.org/146), The -2 version of the patch worked
fine on x86.  http://sourceware.org/bugzilla/show_bug.cgi?id=2873 is the
upstream bug. I'm expecting Drepper to ignore it. This email I sent to
lfs-dev explains the last chunk in the patch.
http://linuxfromscratch.org/pipermail/lfs-dev/2006-August/058008.html .
I don't know the direct reasoning behind the rest of the patch.




More information about the blfs-dev mailing list