libglade-2.6.0

Randy McMurchy randy at linuxfromscratch.org
Sun Aug 6 13:51:47 PDT 2006


tiberius wrote these words on 08/06/06 15:39 CST:

> - the download link is
> 2.5
>   but needs to be
> 2.6

Thanks, I'll fix it right now.


> - it seems to me, that python is needed to compile it, but is marked 
> optional

Here is the checks for Python (in autoconf language)

# check for a copy of python >= 2.0 with the xml.parsers.expat module.
AM_PATH_PYTHON(2.0, [have_python=true], [have_python=false])
if $have_python; then
  jh_python_check='
import sys
try:
    import xml.parsers.expat
except ImportError:
    sys.exit(1)
'
  AC_MSG_CHECKING([for the Python module xml.parsers.expat])
  if AC_RUN_LOG([$PYTHON -c "$jh_python_check"]); then
    AC_MSG_RESULT([yes])
  else
    AC_MSG_RESULT([no])
    have_python=false
  fi
fi
AM_CONDITIONAL(HAVE_PYTHON, $have_python)


This appears to me as an option. Additionally, there is this:

if ! $have_python; then
  echo "*****************************************************"
  echo "  A usable version of python was not found, so the"
  echo "  libglade-convert program was not installed.  This"
  echo "  script requires Python >= 2.0 with expat support."
  echo
  echo "  Some packages require libglade-convert to build"
  echo "  correctly.  If you wish to build one of these"
  echo "  packages, you must install expat and python,"
  echo "  and then rebuild libglade."
  echo "*****************************************************"
  echo
fi


And lastly, I renamed my python and python2.4 executables and
the package built fine, albeit with the message above displayed
at the end of configure.

-- 
Randy

rmlscsi: [bogomips 1003.27] [GNU ld version 2.16.1] [gcc (GCC) 4.0.3]
[GNU C Library stable release version 2.3.6] [Linux 2.6.14.3 i686]
15:43:00 up 4 days, 17:11, 1 user, load average: 0.06, 0.02, 0.00



More information about the blfs-dev mailing list