Latest ORBit2 (or why the BLFS dependency scheme sucks)

Randy McMurchy randy at linuxfromscratch.org
Sat Aug 5 06:36:01 PDT 2006


Greg Schafer wrote these words on 08/04/06 17:30 CST:

> However.... the latest ORBit2 package demonstrates how fragile this system
> is.

Not sure if I agree with you Greg. I cannot speak for other Editors,
but I know I check the deps every time I update a package. There are
times when things are inadvertently overlooked, but I would say that
would be the exception more than the rule.

My feeling is that if the Editor who updates a package does the job
correctly, we really shouldn't ever a problem with the dependency
scheme. Though, it sometimes is a hassle when you have to change
deps in several packages when something changes.

Here's the deal with ORBit2 and popt:

Grepping the sources shows that ORBit2 is a listed dependency for
HAL, GConf and libbonobo. Now all you have to do is the trivial
dependency check of those three packages for popt, and add popt to
the deps if it needs to be. And of course, determine if one is a
dependency of another so it popt isn't listed redundantly.

It may seem like a hassle, but to me is just part of the job. And
I would agree with you 100% if indeed other Editors don't perform
these trivial checks when packages are updated.


> The latest ORBit2 (part of Gnome-2.14.3) no longer depends on popt.
> The popt dependency was actually removed some time ago but the configure
> check mistakenly remained. This has now been fixed.
> 
> This has consequences for BLFS because ORBit2 is so deep in the platform
> stack that all the Gnome deps will now have to be revisited

Not really. Because the very next package you install after ORBit2
is libbonobo, and it requires popt, it comes down to a matter of
moving the dependency from ORBit2 to the libbonobo package. Here
is the check in libbonobo (EOL backslash inserted):

AC_CHECK_LIB(popt, poptStrippedArgv, POPT_LIBS=-lpopt, \
AC_MSG_ERROR([You must have popt version 1.5 or greater installed.]))

This tells us that libbonobo, without a doubt, requires popt.

I will make this change now, and should have GNOME-2.14.3 completed
today (it may be by the end of the weekend).

> But I wouldn't be surprised if Randy (having such
> a fine attention to detail) is already on the case? :-)

Thanks Greg, and no, I haven't yet started the GNOME update as
I've decided to update to Cairo-1.2.0 and GTK+-2.8.20 and got
sidetracked testing a bunch of other GTK+ related packages first.
So, thanks for the heads up.


> It's probably too
> much work to change the BLFS dependency scheme to list all deps explicitly.

Not only would it be a lot of work, but to me would add way too
much clutter to each page. Some package's deps could be a staggering
list of redundant packages.


> PS - I find the dependency info in BLFS usually very accurate.

Speaking for all the BLFS Editors, past and present, thanks for
the compliment.

-- 
Randy

rmlscsi: [bogomips 1003.27] [GNU ld version 2.16.1] [gcc (GCC) 4.0.3]
[GNU C Library stable release version 2.3.6] [Linux 2.6.14.3 i686]
08:10:01 up 3 days, 9:38, 1 user, load average: 0.11, 0.11, 0.09



More information about the blfs-dev mailing list