Apparent KDevelop requirement for 3.3.2

Bruce Dubbs bruce.dubbs at gmail.com
Fri Apr 28 13:45:39 PDT 2006


John Gnew wrote:
> I just tried to build kdevelop 3.3.2 and received the following during
> config,
> 
> checking for Berkeley DB >= 3... configure: error: no - please install
> Berkeley DB >= 3 and <= 4.1
> 
> Either I am doing something wrong, which is very possible, or we need to
> make the Berkeley DB a Requirement of the install.

Berkeley DB is now a part of LFS and expected to be installed.
>From my log:

checking for Berkeley DB >= 3... yes - >=4.1

$ls -l /usr/lib/libdb*

rw-r--r-- 1 root root 1138188 Dec  1 20:40 /usr/lib/libdb-4.3.a
-rw-r--r-- 1 root root     799 Dec  1 20:39 /usr/lib/libdb-4.3.la
-rwxr-xr-x 1 root root  915112 Dec  1 20:39 /usr/lib/libdb-4.3.so
lrwxrwxrwx 1 root root      12 Dec  1 20:40 /usr/lib/libdb-4.so ->
libdb-4.3.so
-rw-r--r-- 1 root root 1138188 Dec  1 20:40 /usr/lib/libdb.a
lrwxrwxrwx 1 root root      12 Dec  1 20:40 /usr/lib/libdb.so ->
libdb-4.3.so

However, I haven't updated to 4.4 on this system yet.

Works fine.
  -- Bruce




More information about the blfs-dev mailing list