Tripwire

Bruce Dubbs bdubbs at swbell.net
Tue Apr 11 21:22:10 PDT 2006


I've been working on Tripwire.  The latest version is 2.4.0.1 (Dec 05)
but it is still pretty crappy.  It won't compile with GCC4.  I created a
patch and will use that.  It still generates a huge number of warnings.

The problem is that it won't install without what appears to be
extraordinary efforts without an executable program that is named
sendmail.  The book says an MTA is optional, but that goes back to the
original writeup for the book (o4/03/03).

The options I see are:

1. Make an MTA required.
2. Change the install script to ignore the mail issue with a sed.
3. Make an empty sendmail executable:
    touch /usr/bin/sendmail; chmod +x /usr/bin/sendmail
4. Remove the Makefile execution of the initial setup and
   show the user how to do it manually instead of using the supplied
   script.

I'm looking for opinions on the best way to go here.

  -- Bruce



More information about the blfs-dev mailing list