Xorg 7 - various comments

Chris Staub chris at beaker67.com
Sat Apr 8 06:28:08 PDT 2006


Ag Hatzim wrote:
> I am running make as a user and no matter if i run the make install as
> root or with sudo,Xorg server isn't installed SUID root,as it should.

I run make as a user and then make install as root - same issue - 
/usr/bin/Xorg isn't being installed suid root.

> I would like to know if this is reproducable from others,just to satisfy 
> my curiosity.
> 
> Here is the relevant part of my log.
> #-------------------------------#
> test -z "/usr/bin" || mkdir -p -- "/usr/bin"
>   /bin/sh ../../libtool --mode=install /usr/bin/install -c 'Xorg'
>   '/usr/bin/Xorg'
>   /usr/bin/install -c Xorg /usr/bin/Xorg
>   (cd /usr/bin && rm -f X && ln -s Xorg X)
> #-------------------------------#   
> 
> Anyway just to keep an eye on this.

Here is the problem, in hw/xfree86/Makefile...

install-exec-local: install-binPROGRAMS
         (cd $(DESTDIR)$(bindir) && rm -f X && ln -s Xorg X)
#       chown root $(DESTDIR)$(bindir)/Xorg
#       chmod u+s $(DESTDIR)$(bindir)/Xorg

When I run configure as a regular user, the chmod is commented out. When 
I run it as root, it is not. It's like this on both 1.0.1 and 1.0.2.



More information about the blfs-dev mailing list