Gnome's Evince and Poppler

Hugo Villeneuve hugo at hugovil.com
Thu Apr 6 12:46:43 PDT 2006


> On 4/6/06, Randy McMurchy <randy at linuxfromscratch.org> wrote:
> >
> > Best I can tell, Evince wants a minimum of version 0.5.1 of the Poppler
> > library. The 0.5.x versions are development snapshots. The 0.4 x series
> > is current stable.
> 
> I don't mind going to a development snapshot of Poppler.  Here's
> something to think about WRT evince-0.5.  From the NEWS file:
> 
> ==============
> Evince   0.5.1
> ==============
> ...
> Bug Fixes:
> ...
>     * Correctly interoperate with DBUS 0.60
> 
> So, if we decide to use dbus-0.60 (not that we necessarily will), it
> looks like we'd want to use evince-0.5.1+ and, hence, poppler-0.5.x.
> 
> > Any advice from anyone on which way to go here? KDEgraphics uses Poppler
> > as well, but I'm not sure what version, and I don't know how much
> > API/ABI changes there are between Poppler 0.5.x and 0.4.x.

Hi,
  I'm using evince-0.5.2 and poppler-0.5.1 without problems. The only API/ABI issue I have with poppler-0.5.1 is with abiword-2.4.2 (patch attached).

  Hugo.

-- 
-------------------------
Hugo Villeneuve

hugo at hugovil.com
http://www.hugovil.com
-------------------------
-------------- next part --------------
A non-text attachment was scrubbed...
Name: abiword-2.4.2-poppler.patch
Type: application/octet-stream
Size: 911 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-dev/attachments/20060406/cb78cbe5/attachment.obj>


More information about the blfs-dev mailing list