pkgconfig-0.20

DJ Lucas dj at linuxfromscratch.org
Thu Nov 24 19:08:24 PST 2005


Randy McMurchy wrote:

> I guess I'm not sure what you are asking, but have you tried
> 'man pkg-config'?

No, I didn't.  I should have looked first....I started asking the 
question about the implicit deps and threw that in at the last minute 
not having much knowledge of pkg-config.  'pkg-config --libs 
gnome-vfs-2.0' looks like everything I needed to know.  IOW, the old 
behavior looks as though it has been restored.  Being unfamiliar, I'm 
still not absolutely certain...so I'll just try it without the patch.

What I was asking (without knowing what I was asking) was this:  If I 
were to call 'pkg-config --libs ORBit-2.0', will it pull in all of it's 
dependencies too.  It does, pkgconfig-0.17 broke this, and IIRC 0.18 did 
as well.  I haven't looked at the changelog to see when exactly it was 
fixed, but it works like it should now AFAICT.  I don't understand why 
the change took place to begin with.  There is no reason I should have 
to specify the entire dependency list, when they are absolutely required 
anyway.

-- DJ Lucas



More information about the blfs-dev mailing list