pkgconfig-0.20

DJ Lucas dj at linuxfromscratch.org
Thu Nov 24 18:27:47 PST 2005


Hey guys.  A while ago, pkgconfig-0.17 IIRC, the behaviour was changed 
not to allow implicit dependencies.  IOW, prior to 0.17, if I checked 
for gtk+, glib's linker flags would also be pulled in because it depends 
on glib.  There was talk of reversing this new default behavior, 
however, I can't find the thread (it was on an OOo patch).  There was a 
configure option to return it to that behaviour, again IIRC however, 
there was talk of reversing that default and a link to some discussion 
elsewhere.  My memory is rather fuzzy and I can't seem to find this 
discussion.

The reason I ask is that one of the OOo patches can be removed if 
pkgconfig has been changed back to the way it was before.  I can 
envision a seemingly simple testcase, but I don't know how to use 
pkgconfig directly.

TIA for any hints.

-- DJ Lucas




More information about the blfs-dev mailing list