BLFS Bugzilla #1690

Randy McMurchy randy at linuxfromscratch.org
Thu Nov 17 07:41:27 PST 2005


Hi all,

Noted in http://blfs-bugs.linuxfromscratch.org/show_bug.cgi?id=1690
it says that if libvorbis-1.1.1 is compiled using GCC-4.0.x, that
files produced using libvorbis will be corrupted.

I cannot duplicate this behavior. Perhaps it requires using special
optimizations ( this is mentioned in the bug at
http://trac.xiph.org/cgi-bin/trac.cgi/ticket/583 )

I ripped a file using Sound-Juicer, which my understanding is that
it uses libvorbis to encode the data and make a .ogg file. This
file plays fine using ogg123. I cannot tell any difference in the
.ogg file from playing the CD directly (sound quality wise).

Has anybody else noticed the behavior mentioned in this bug?

-- 
Randy

rmlscsi: [GNU ld version 2.15.94.0.2 20041220] [gcc (GCC) 3.4.3]
[GNU C Library stable release version 2.3.4] [Linux 2.6.10 i686]
09:32:00 up 53 days, 18:56, 3 users, load average: 0.00, 0.16, 0.44



More information about the blfs-dev mailing list