gcc-4 and SBU's

Randy McMurchy randy at linuxfromscratch.org
Wed Nov 2 09:43:31 PST 2005


Archaic wrote these words on 11/02/05 11:34 CST:
> I just realized a possible problem. I was about to update the dhcpcd
> package and started wondering about SBU timing differences between
> gcc-3.4.4 and gcc-4.0.2 and if I would be using an invalid timing.

>From what I've noticed, there is very little difference between SBU
timings with the LFS version that has GCC-3.4.4 and GCC-4.0.x. The
combination of GCC/binutils/Glibc between recent LFS versions seemed
to produce very close SBU timings.

> Then
> I realized that compilation problems might hit with gcc-4 and not gcc-3.
> I do not have a current lfs-svn system, so I'm going to unassign myself
> from dhcpcd.

This one *is* important. I'm not sure editors should update packages
until it is known to build successfully using the target toolchain.
For SVN, that would include GCC-4.0.x. You probably did the right
thing by not updating the package until you are certain it can
compile using GCC-4.0.x.

-- 
Randy

rmlscsi: [GNU ld version 2.15.94.0.2 20041220] [gcc (GCC) 3.4.3]
[GNU C Library stable release version 2.3.4] [Linux 2.6.10 i686]
11:38:59 up 38 days, 21:03, 3 users, load average: 0.05, 0.14, 0.26



More information about the blfs-dev mailing list