GCC-3.3.x

Archaic archaic at linuxfromscratch.org
Sun Apr 24 22:34:03 PDT 2005


On Mon, Apr 25, 2005 at 12:19:28AM -0500, Randy McMurchy wrote:
> 
> I'm not sure that because there may be some binary version of some
> package out there that needs libstdc++.so.5 is a compelling reason.

As far as binary packages, if the book contains that package, then I
wouldn't cater to the binary form. But for plugins and such I have no
reference because I don't use anything that needs the compat libs nor do
I know of anything that requires it. One thing to keep in mind is if the
gcc section is done, there isn't any extra maintenance at this point to
keep it.

> So, unless someone comes up with some good reason why we need to
> keep GCC-3.3.x in the book, it will vanish in a couple of days.

I do not know if this affects anyone else, but I have to compile mplayer
with 3.3.x else it often crashes. This was on 2 different machines
running a cvs version of the via driver, the nv driver, and verious
nvidia drivers all on xorg 6.8.2. Also, using mplayer 1.0pre6a and
1.0pre7. The output of mplayer suggested a possible compiler
incompatibility. This problem doesn't have enough priority for me to
investigate so I just use 3.3.5. Either way, I don't need the book for
that so I'm not suggesting it stay to satisfy my situation.

-- 
Archaic

Want control, education, and security from your operating system?
Hardened Linux From Scratch
http://www.linuxfromscratch.org/hlfs




More information about the blfs-dev mailing list